2

I'm using Firefox 31.0, which is up-to-date as of the writing of this question, on Windows 8.1, logging into SE by means of a Google Account.

This weekend the red box with the number of unread inbox messages is being 'sticky', as is the green box with the recent 'achievements'.

The inbox messages problem

The red box is showing that I have 1 unread inbox message. I go to my inbox, read the message, and the number persists. I can go to my user panel and click on the message there, or come to meta and go back to the main site, and the indicator clears, but then it reappears. Logging out and logging back in again seems to have no effect.

The achievements problem

The green box indicating changes in reputation and achievements is also persisting after I have clicked on it; furthermore, the drop-down summary given there does not agree with the reputation changes shown on the user page (e.g. I have an accepted answer which is not showing in the drop-down).

Blue indicators are working

The blue circles that show on the user's summary page, which show the number of unread messages and the reputation changes, are acting normally. If I click on the answer there, or the reputation changes, it clears the blue numerical indicators as always.


This behavior started this weekend. I haven't seen it happen before today. I should also mention that I have the Firefox add-on Stack Alert installed, which broke some weeks ago.

Clicking on the alert button gives the error.

An error has occurred. Details are below:

An error has occurred.

Details: key is not valid for passed access_token, token not found..

I will disable the add-on since it isn't working.


I have removed (not just disabled) the Stack Alert add-on, logged out of Stack Exchange, and out of Google, logged back into G&FH.SE, and the green and red indicators are back in the status bar.

I find the red inbox messages indicator more concerning than the green one. Especially since Stack Alert broke and I don't have that indicator to alert me to new inbox messages, the red indicator is the one that will show someone has commented or tried to ping me from chat. It would be a shame if users quit looking at their inbox because of a false positive on the inbox indicator.

5
  • And now, suddenly, after shutting down Firefox and logging all the way out again -- making sure I was logged out of SE and also logged out of Google -- everything is fine.
    – Jan Murphy Mod
    Aug 17 '14 at 21:52
  • I saw similar symptoms over the weekend using Internet Explorer 11 but, without taking any SE/Google logout actions, just an overnight reboot, my perception is likewise that those symptoms have now disappeared i.e. I do not think that you were imagining the problem.
    – PolyGeo Mod
    Aug 17 '14 at 23:47
  • I have also experienced some intermittent problems this afternoon logging into chat e.g. SE prompts me to log into G&FH.SE before logging into chat when I am already logged in.
    – Jan Murphy Mod
    Aug 18 '14 at 0:04
  • 1
    I just logged into Roots and the Genealogy weekly chat without a problem so I cannot reproduce this one but with you being so thorough I do not doubt that it is happening for you. I have not observed any recent difficulties doing so either. With the bug tag you have attached to your question, my understanding is that the attention of someone from the SE network team will be gained so hopefully we may see some feedback. StackStatus suggests that some work was being done over the weekend.
    – PolyGeo Mod
    Aug 18 '14 at 0:12
  • @PolyGeo now that the system 'day' has changed over, the reputation changes that were missing before are reflected in the drop-down box. I suspect you are right, and this is an artifact of the work done on the system this weekend.
    – Jan Murphy Mod
    Aug 18 '14 at 0:35
4

We had problems with a datacenter test that left our caching layer in a partially broken state.

All issues should now be resolved.

Also, see https://meta.stackoverflow.com/questions/268957/topbar-notifications-dont-go-away

1
  • Sorry! I did see news about the test on Saturday, but by Sunday when I wrote up this bug report, I had forgotten about the test. :-(
    – Jan Murphy Mod
    Aug 18 '14 at 21:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .